Issue with domain registrar nameservers
Incident Report for Cloud Access
Resolved
At 1735 our monitoring system flagged an issue with our domain registrar's nameserver pointers. This issue has been resolved - if you experience any further issues with our services, you may need to clear your local DNS cache. We will continue to monitor the system.
Posted 9 days ago. Dec 03, 2018 - 17:57 GMT
This incident affected: Website, Control Panel, and API.